Solutions

IntelligenceCenter Archived Report shows "There are no records for this table"

Solutions ID:    KB4021
Version:    1.0
Status:    Published
Published date:    09/16/2010
 

Problem Description

A couple of days after installation, I scheduled a TCP Health report to run. When I view the report in the archive, it shows no data. However, when I run the report in real-time, it shows data.

Resolution

The reason that the archived report shows no data is that it was scheduled to run before the selected time period of data had been collected. For example, if you run a "Year" report before IntelligenceCenter has been running for a year, there will not yet be any data in the Yearly table of the DataCollector database. However, if you run the report after IC has been running for a year, the DC will have the appropriate data and be able to generate the Yearly report.

When you schedule a report you can select from "Custom", "Day", "Week", "Month" and "Year." When scheduling a report, be sure to pick a time range that is within the installation range of IC. If your selected "Year" and schedule the report on September 9, 2010 24:00. The start date will be September 9, 2009 24:00 and end date is September 9, 2010 24:00. Make sure you have sufficient data to avoid getting  the "There are no records for this table" error in the generated report.

 


Rate this Page

Please take a moment to complete this form to help us better serve you.

Did this document help answer your question?
 
 
If you are finished providing feedback, please click the RATE CONTENT button. Otherwise, please add more detail in the following text box and then click RATE CONTENT.
 
 

Your response will be used to improve our document content.

Ask a Question