January 10, 2012 - Multiple PostgreSQL vulnerabilities in IntelligenceCenter
High, CVSS v2 base score: 7.4 (AV:A/AC:M/Au:S/C:C/I:C/A:C)
CVE-2009-3229 - CVSS v2 base score: 2.7 (AV:A/AC:L/Au:S/C:N/I:N/A:P)
IntelligenceCenter installs and uses a version of PostgreSQL that has several publicly documented vulnerabilities. The most severe vulnerability allows an attacker to gain complete control over an IntelligenceCenter installation.
All versions of IntelligenceCenter prior to version 184.108.40.206 are vulnerable.
IntelligenceCenter 3.x installs and uses PostgreSQL version 8.4. IntelligenceCenter 2.x installs and uses PostgreSQL 8.2. Each version of PostgreSQL has several publicly documented vulnerabilities.
The most severe vulnerability allows an attacker to gain complete control over an IntelligenceCenter installation. The attacker can view and modify configuration data as well as data sent to and from IntelligenceCenter. An attacker can also render IntelligenceCenter completely unresponsive for administrative control as well as data transmission.
When IntelligenceCenter is deployed behind a firewall, as is recommended, an attacker must gain access from the internal network in order to mount an attack. The CVSS base scores included in this advisory are based on this deployment scenario.
If IntelligenceCenter is deployed outside of the firewall. the CVSS base score for all CVEs listed would be higher. The CVSS base score for this security advisory would be a 8.5 (AV:N/AC:M/Au:S/C:C/I:C/A:C).
IntelligenceCenter 220.127.116.11 contains an upgrade to PostgreSQL 8.4.7 fixing the CVEs documented in this security advisory.
Blue Coat recommends that IntelligenceCenter be deployed behind a firewall. Additional constraints on what IP addresses can be used to connect to IntelligenceCenter will greatly limit the ability to attack an IntelligenceCenter installation.
IntelligenceCenter 3.2 - a fix is available in 18.104.22.168. The fix is available to customers with a valid BlueTouch Online login from bto.bluecoat.com/download/product/33.
IntelligenceCenter 3.1 and earlier - please upgrade to a later version.
CVE-2009-3229 - http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2009-3229
2012-01-17 Changed status to final
Rate this Page
Please take a moment to complete this form to help us better serve you.